Back to overview
Degraded

Gamepanel Issues

Aug 20 at 01:32am CEST
Affected services
Game Panel - Website

Resolved
Aug 20 at 02:24am CEST

We have resolved any issues with the panel. Additionally we have pushed a visual update. Enjoy!

Created
Aug 20 at 01:32am CEST

We are currently aware of issues with our game panel and are working to get these resolved as soon as possible. All servers and features are still accessible and no data has been lost.